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Image Editing Using Paint Shop Pro 6

Introduction

'What is Paint Shop Pro & What can it do?'

Paint Shop Pro is a mid-range graphics package. It is primarily used for creating, viewing and editing graphics for screen and print. It is still used by graphic professionals. 

'How much does it cost and where can I get it'

Paint Shop Pro is available as a shareware 30-day trial. You will be given 60 days grace and after that you are obliged to register and purchase. You can get it from the cover disk of an Internet magazine or download it using Netscape from any of the following URL's.

http://www.jasc.com/

http://www.download.com/

ftp://sunsite.doc.ic.ac.uk/packages/simtelnet/win95/graphics/ 

Four quick and useful things that Paint Shop Pro can do

1. Capture images from the screen

This can be useful if you want to have evidence from a program you are running or you want to write a manual for your program.

2. Resize images

You can crop an image so that you have a better composition and you can make your image bigger or smaller so that it fits your production better. You can capture an image from the Internet and save it as your wallpaper or resize a photograph so it fits better on your web page. 

3. Reformat images

This allows you to convert an image so that you can use it in another application, say a photograph you have scanned that you want to put on a web page.

Common Picture formats: 


GIF - A 256 colour 8 Bit graphic 
Used for line drawings and small photographs

JPG - A Joint Pictures Group image
Used for photographs at least 100x100 pixels 

BMP - A Windows Bitmap
General purpose & printing 

TIF - A Tagged Image File Format
General purpose & printing

PSP - Paint Shop Pro
Native format 

4. Print several copies of the same image on one sheet

One example comes from a student who wanted several copies of an image from a passport photograph.

Some other things Paint Shop Pro can do

Replace colours in and existing image

This uses the dropping tool and the colour replacement tool, plus some selection methods. 

Create images using the drawing tools

There are various tools that can be used to create lines, shapes or text.

Starting Paint Shop Pro 

Click on Start, Programs, Tools & Accessories, Accessories, Paint Shop Pro 6. If you are using your own system you will know how to start Paint Shop Pro. This will give you the PSP start up screen with the Title bar, the File menu and the Tool bar across the top.
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The File Menu ought to be familiar from Word or other Microsoft packages but notice Revert (currently greyed out) which allows you to go back to the last previously save state and Print Multiple Images 

The tool palette runs down the left hand side and is shown below:
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Arrow
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Zoom
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Deformation
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Crop
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Mover
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Selectiom
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Freehand selection
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Magicwand
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Dropper
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Paint Brush
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Clone Brush
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Colour Replacer
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Retouch
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Eraser
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Picture Tube
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Air Brush
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Flood Fill
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Text
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Draw
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Preset Shape
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Vector Object Selection

Cropping and resizing an image
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Original image
Cropped and resized

Use Blackboard to download the photo of Pippin. Select the cropping tool. Select the area of the image that you want by clicking and dragging from the top left corner to the bottom right or vice versa. Click on Image in the Tool Bar then Crop. Resize the image so that it has an actual print width of 3" (7.5 cm). Save the new image on your homespace as a jpeg. Use Save As and give the image a NEW name for safety.

Creating a screen capture

Setting up the Capture Parameters

Click on Capture in the File Menu. You will see:
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You get choices for the capture area. I use Object or Area. We shall practice area. You have options for activating the capture. I use F11. If you have a lot of images to capture in a session check the Multiple captures box. You can either start capturing now or click on OK and start capturing later. You do this by using Shift C or from the Capture menu. PSP minimises itself. Press the F11 key when you actually want to start the capture. 

Start Capturing

Click on Capture Now. PSP will minimise. Minimise everything so you see the desktop. Press the F11 key. The cursor will change to a cross. Move the cursor to the top left hand corner of the screen and left click with the mouse. Move to the bottom right hand corner of the screen and left click with the mouse again. PSP will open up with a picture of the screen. 

Size and save the image for your manual 

Click on Image => Resize. Change the actual width to 4 inches (or 10cm). The image will be resized. Now click on Save as. Type the name desktop. 

Using preset shapes

Create a new image

Click on File => New from the top menu. Then select the size of image and number of colours you wish to use. A standard PC screen uses 640x480 pixels, although larger 17-inch monitors on Windows NT workstations will be using 1024x768.

Screen Resolutions



Name
Resolution
Usually used on 

VGA 
640x480
14" Monitors

SVGA 
800x600
15" Monitors

SVGA 
1024x768
17" Monitors

For the following exercise select 1024x768 and 16.7 Million (24-bit) colour. Check the background is set to white.

Selecting and drawing Preset Shapes

Setting the colour

Colour Palette
Colour Dialogue Box
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Go into coloured part of the Color Palette and set the foreground colour to green by left clicking. If you can't get it exactly green, do the best you can and then click in the foreground colour box. This will bring up the Color Dialog box. Now Set the background colour to red.

Setting the shape



Click on the Preset Shapes icon  Open up the Tool Options dialog box either by right clicking on the Preset Shapes icon in the Tool Palette or using the Toggle Tool Options icon in the tool bar. You will be presented with a dialog box like this.
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Select the shape type and style here. If you have a stroked (open) shape set the line width. Antialias should be checked but Create as vector unchecked. You will have trouble, as a beginner, if you leave this box checked.

You draw a shape by dragging with a mouse button pressed. If you draw a shape with straight edges it the starting point defines a corner but an ellipse or circle starts from the centre. 

A stroked style draws a hollow shape and the boundary is set by the line width. If you use the left mouse button you get the foreground colour and the right button gives the background colour. A filled style gives you a solid shape with colours as before. A stroked and filled style gives a solid shape with the boundary of one colour and the fill of the other. The left mouse button gives boundary = foreground colour and fill = background colour. You get the reverse effect with the right mouse button. 

Exercise

First check that the foreground colour is set to GREEN and the background colour is set to RED. By using the left and right mouse buttons: Draw a stroked GREEN triangle and stroked RED triangle. Draw a filled GREEN ellipse and filled RED ellipse. Draw a RED rectangle with a GREEN border and a GREEN rectangle with a RED border.

Using the brush, copy and paste.

In this section we shall draw a symmetrical tree with red fruit. Save regularly.
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Create a new image 200x200 pixels with a white background. Now set the foreground Colour to green and the background to brown in the Color Palette. Select the brush and set the brush width to 5 pixels (or something like that). Draw the outline of half a tree with a brown trunk and green leaves.
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Select the half -tree using the Selection Tool. Copy the selection. Paste the half-tree into this image as a new selection. Mirror the second image using Image Mirror. The graphic on the left shows the process after the paste but before the mirror.


Note that there is very little white space on the right hand edge.
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Now use the brush to close the top of the trunk and, if necessary, the top of the tree. These two areas must be paint tight because we are going to use Flood Fill. You may need to zoom in. If you set the brush width to 1 you can edit the image pixel by pixel.
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Use Flood Fill 
to colour the top and the trunk of the tree. Now put in the red fruit.



First exercise with the Color Replacer. 

Creating a new image then changing one colour to another colour 

Create a new image on a white background

Set the tool foreground to green and the background to red. 
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Draw a green ellipse putting the cursor at the 'centre' of your intended ellipse and dragging the pointer out while you keep the LEFT mouse button clicked. Draw a red rectangle overlapping the ellipse. Put the pointer at the top left hand corner and drag down and right whilst keeping the RIGHT LEFT mouse button clicked. 

Change the green to blue

1. Change the BACKGROUND colour to blue using the Color Palette. Keep the foreground colour green. 

2. Select the Color Replacer PRIVATE "TYPE=PICT;ALT=Color Replacer"
. Go anywhere in the image and double click the RIGHT mouse button. The green will be replaced by blue.

Second exercise with the Color Replacer

This is designed to show the effect of the tolerance setting.

1. Create a new image.

2. Draw a green ellipse.

3. Change the foreground to green.

4. Go back to the foreground palette, click on it and add 40 units of red.

5. Draw a second green ellipse separated from the first.

6. Draw a red rectangle overlapping the ellipses.

7. Change the background colour to blue.

8. Replace the foreground colour with the background.

9. Open the tools Option window and check that the tolerance is set to a low value. Which colour changes? Undo the colour change so that you have the two green ellipses back. Select the colour replacer, tools option, and increase the tolerance to 32. Now use the colour replacer. What happens now?

Third Exercise with the Colour Replacer

1. Changing one colour to several other colours in an existing image

Open the butterfly file (download from Blackboard). Click File => Open. Remember to have the correct format selected. This image comes with PaintShopPro. If you are using these notes on your own you can obtain this file from the Images sub-directory of your PaintShopPro installation. You will need to merge the layers. (Layers =>Merge=>All.)
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2. Change the foreground palette to orange

Select the dropper. Put the dropper anywhere on the orange parts of the butterfly and left click. The foreground palette will change to orange. 

3. Change the background palette to blue.

Go into the Color Palette and select a bright blue. Right click and the background colour will change. 

4. Change the colours in the butterfly.

Select the Color Replacer and RIGHT click twice anywhere in the image. The butterfly will change to blue. 

Change the lower wings to magenta

1. Change the foreground palette to magenta

2. Go to the color Palette and

select magenta. Left click.

You can stay in the Color

Replacer while you are

doing this. Choose the

selection tool and select the

bottom wings of the butterfly.

Your screen ought to look

something like this
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3. Select the Color Replacer. Go anywhere in the image and double click the left mouse button. The bottom wings change colour.

4. Your image should look

 something like this. The

 selection box has not

 been cancelled yet.
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A note on saving your work. It is worth saving your work as you go. One of the best moments is when you think, "That looks good! I wonder if I can improve it." You can save several versions e.g. butterfly1 butterfly2 etc. If you make a mess of the current image you can revert to the previous saved image using File => Revert (highly recommended)!

Printing multiple images on one sheet. 

Open the Print Dialog Box

Click on File => Print Multiple Images. You will be given small images of all the images you have open. You get a menu by right clicking.
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Figure 1

Menu for selecting the Print Options
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Figure 2

Menu for manipulating the images

You can drag as many images as you want onto the page. You can manipulate the image using a menu obtained by right clicking. See fig 1 above. You can then use AutoArrange to fit them onto the page. Once you have dragged an image onto the printer page you can get another menu for manipulating the image(s). See figure 2 above.

If you have different images they will be arranged on the page in the order they were created when you use Auto Arrange.

Third exercise with the Color Replacer (Advanced)

This is designed to show the effect of the tolerance setting.

Create a new image

Draw the first shape

Change the foreground green. Ensure that the the colour balance is: 
R=0
G=255
B=0
Draw a green ellipse.

Draw the second shape

Go back to the foreground palette, click on it and add 40 units of red. Draw a second green ellipse separated from the first. See Figure 1 below.
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Change the background colour to blue with a low tolerance.

Set the Color Replacer Properties by openning the Tools Option window, select the tab with two stars and check the tolerance is set to a low value: see Figure 2 above. Now replace foreground colour with the background. Which colour changes? 

Change the background colour to blue with a higher tolerance.

Undo the colour change so you have the two green ellipses back. Select the Color Replacer, select the tools options and increase the tolerance 32 or more. Now use the Color Replacer. This time both ellipses change to blue.
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